PLEASE LEAVE YOUR SUGGESTION AND COMMENTS

PLEASE LEAVE YOUR SUGGESTION AND COMMENTS

Monday 30 January 2012

Redistribution on both routers R2 and R3









































R2 Config:







interface Serial0/0
 ip address 192.168.12.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 172.16.24.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 10
 redistribute ospf 10 route-map o2e
 network 192.168.12.0
 auto-summary
!
router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 redistribute eigrp 10 subnets route-map e2o
 network 172.16.24.0 0.0.0.255 area 0
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.12.0 0.0.0.255
access-list 10 permit 192.168.4.0 0.0.0.255
access-list 20 permit 192.168.2.0 0.0.0.255
access-list 20 permit 192.168.15.0 0.0.0.255
access-list 20 permit 192.168.13.0 0.0.0.255
access-list 30 deny   192.168.3.0 0.0.0.255
access-list 50 permit 172.16.24.0 0.0.0.255
access-list 50 permit 172.16.46.0 0.0.0.255
access-list 50 permit 172.16.1.0 0.0.0.255
access-list 50 permit 172.16.34.0 0.0.0.255
access-list 60 deny   172.16.2.0 0.0.0.255
!
route-map e2o permit 10
 match ip address 10
 set metric 100
 set metric-type type-2
 set tag 10
!
route-map e2o permit 20
 match ip address 20
 set metric 200
 set metric-type type-1
 set tag 20
!
route-map e2o permit 30
 match ip address 30
!
route-map e2o deny 40
 match tag 50
 set metric 300
 set metric-type type-1
 set tag 30
!


route-map o2e permit 10
 match ip address 50
 set metric 100 100 100 100 100
 set tag 50
!
route-map o2e permit 20
 match ip address 60
!
route-map o2e deny 30
 match tag 10 20 30
!


R3 Config


!
interface Serial0/0
 ip address 192.168.13.2 255.255.255.0
 serial restart-delay 0
!
interface Serial0/1
 ip address 172.16.34.1 255.255.255.0
 serial restart-delay 0
!
router eigrp 10
 redistribute ospf 10 route-map o2e
 network 192.168.13.0
 auto-summary
!
router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute eigrp 10 subnets route-map e2o
 network 172.16.34.0 0.0.0.255 area 0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.12.0 0.0.0.255
access-list 10 permit 192.168.4.0 0.0.0.255
access-list 20 permit 192.168.2.0 0.0.0.255
access-list 20 permit 192.168.15.0 0.0.0.255
access-list 20 permit 192.168.13.0 0.0.0.255
access-list 30 deny   192.168.3.0 0.0.0.255
access-list 50 permit 172.16.24.0 0.0.0.255
access-list 50 permit 172.16.46.0 0.0.0.255
access-list 50 permit 172.16.1.0 0.0.0.255
access-list 50 permit 172.16.34.0 0.0.0.255
access-list 60 deny   172.16.2.0 0.0.0.255
!
route-map e2o permit 10
 match ip address 10
 set metric 100
 set metric-type type-2
 set tag 10
!
route-map e2o permit 20
 match ip address 20
 set metric 200
 set metric-type type-1
 set tag 20
!
route-map e2o permit 30
 match ip address 30
!
route-map e2o deny 40
 match tag 50
 set metric 300
 set metric-type type-1
 set tag 30
!
route-map o2e permit 10
 match ip address 50
 set metric 100 100 100 100 100
 set tag 50
!
route-map o2e permit 20
 match ip address 60
!
route-map o2e deny 30
 match tag 10 20 30
!

Output on R1:

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial0/1
C    192.168.13.0/24 is directly connected, Serial0/2
C    192.168.15.0/24 is directly connected, Serial0/0
     172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks
D EX    172.16.46.0/24 [170/26137600] via 192.168.13.2, 00:20:08, Serial0/2
                       [170/26137600] via 192.168.12.2, 00:20:08, Serial0/1
D EX    172.16.34.0/24 [170/26137600] via 192.168.13.2, 00:20:08, Serial0/2
                       [170/26137600] via 192.168.12.2, 00:20:08, Serial0/1
D EX    172.16.24.0/24 [170/26137600] via 192.168.13.2, 00:20:09, Serial0/2
                       [170/26137600] via 192.168.12.2, 00:20:09, Serial0/1
D EX    172.16.1.1/32 [170/26137600] via 192.168.13.2, 00:20:09, Serial0/2
                      [170/26137600] via 192.168.12.2, 00:20:09, Serial0/1
D    192.168.4.0/24 [90/2297856] via 192.168.15.1, 00:48:45, Serial0/0
D    192.168.5.0/24 [90/2297856] via 192.168.15.1, 00:48:46, Serial0/0
D    192.168.1.0/24 [90/2297856] via 192.168.15.1, 00:48:46, Serial0/0
D    192.168.2.0/24 [90/2297856] via 192.168.15.1, 00:48:46, Serial0/0
D    192.168.3.0/24 [90/2297856] via 192.168.15.1, 00:48:46, Serial0/0

R4 Output:


R4#wr
Building configuration...
[OK]
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

O E2 192.168.12.0/24 [110/100] via 172.16.34.1, 00:21:14, Serial0/1
                     [110/100] via 172.16.24.1, 00:21:14, Serial0/0
O E1 192.168.13.0/24 [110/264] via 172.16.34.1, 00:21:14, Serial0/1
                     [110/264] via 172.16.24.1, 00:21:14, Serial0/0
O E1 192.168.15.0/24 [110/264] via 172.16.34.1, 00:21:14, Serial0/1
                     [110/264] via 172.16.24.1, 00:21:14, Serial0/0
     172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
C       172.16.46.0/24 is directly connected, Serial0/2
C       172.16.34.0/24 is directly connected, Serial0/1
C       172.16.24.0/24 is directly connected, Serial0/0
O       172.16.1.1/32 [110/65] via 172.16.46.2, 00:42:32, Serial0/2
O       172.16.2.1/32 [110/65] via 172.16.46.2, 00:42:32, Serial0/2
O E2 192.168.4.0/24 [110/100] via 172.16.34.1, 00:21:16, Serial0/1
                    [110/100] via 172.16.24.1, 00:21:16, Serial0/0
O E2 192.168.1.0/24 [110/100] via 172.16.34.1, 00:21:17, Serial0/1
                    [110/100] via 172.16.24.1, 00:21:17, Serial0/0
O E1 192.168.2.0/24 [110/264] via 172.16.34.1, 00:21:17, Serial0/1
                    [110/264] via 172.16.24.1, 00:21:17, Serial0/0
R4#

No comments: