In the above practical, I wanted to revise whatever I learned in CCNP route EIGRP:
Above diagram is in the GNS3 and to the right in the logical diagram of the network.
I covered following eigrp over
1> multipoint NBMA
2> point to point NBMA
3> point to multipoint
4> redistribution
I am going to paste the config of the R1 and R5. And outout from R7 and R4
R1 Config
interface Loopback1
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
no ip split-horizon eigrp 10
no ip split-horizon eigrp 11
serial restart-delay 0
!
interface Serial0/0.1 point-to-point
ip address 192.168.1.1 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 103
!
interface Serial0/0.2 point-to-point
ip address 192.168.2.1 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 104
!
interface Serial0/0.3 multipoint
ip address 10.10.10.4 255.255.255.0
snmp trap link-status
frame-relay map ip 10.10.10.1 105 broadcast
!
router eigrp 10
redistribute eigrp 11
network 172.16.1.0 0.0.0.255
network 192.168.1.0
network 192.168.2.0
no auto-summary
!
router eigrp 11
redistribute eigrp 10
network 10.10.10.0 0.0.0.255
no auto-summary
!
R5 Config
interface Loopback1
ip address 172.16.5.1 255.255.255.0
!
interface Serial0/0
ip address 10.10.10.1 255.255.255.0
encapsulation frame-relay
no ip split-horizon eigrp 11
serial restart-delay 0
frame-relay map ip 10.10.10.2 506 broadcast
frame-relay map ip 10.10.10.3 507 broadcast
frame-relay map ip 10.10.10.4 501 broadcast
!
router eigrp 11
network 10.10.10.0 0.0.0.255
network 172.16.5.0 0.0.0.255
no auto-summary
!
OUTPUT from R4
R4#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 6 subnets
C 172.16.4.0 is directly connected, Loopback1
D EX 172.16.5.0 [170/2809856] via 192.168.2.1, 00:33:02, Serial0/0.1
D EX 172.16.6.0 [170/3321856] via 192.168.2.1, 00:33:02, Serial0/0.1
D EX 172.16.7.0 [170/3321856] via 192.168.2.1, 00:33:02, Serial0/0.1
D 172.16.1.0 [90/2297856] via 192.168.2.1, 00:58:44, Serial0/0.1
D 172.16.3.0 [90/2809856] via 192.168.2.1, 00:50:57, Serial0/0.1
10.0.0.0/24 is subnetted, 1 subnets
D EX 10.10.10.0 [170/2681856] via 192.168.2.1, 00:33:03, Serial0/0.1
D 192.168.1.0/24 [90/2681856] via 192.168.2.1, 00:58:46, Serial0/0.1
C 192.168.2.0/24 is directly connected, Serial0/0.1
Output from R7
R7#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 6 subnets
D EX 172.16.4.0 [170/3321856] via 10.10.10.1, 00:27:05, Serial0/0
D 172.16.5.0 [90/2297856] via 10.10.10.1, 00:42:51, Serial0/0
D 172.16.6.0 [90/2297856] via 10.10.10.2, 00:42:51, Serial0/0
C 172.16.7.0 is directly connected, Loopback1
D EX 172.16.1.0 [170/2809856] via 10.10.10.1, 00:27:05, Serial0/0
D EX 172.16.3.0 [170/3321856] via 10.10.10.1, 00:27:05, Serial0/0
10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Serial0/0
D EX 192.168.1.0/24 [170/3193856] via 10.10.10.1, 00:27:07, Serial0/0
D EX 192.168.2.0/24 [170/3193856] via 10.10.10.1, 00:27:07, Serial0/0
Why split horizon is required on serial0/0 on R1 and R5??
No comments:
Post a Comment